<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js no-svg">
	<head>
		<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<title>Princeton should continue to fund local public television station - Planet Princeton</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="zIF6eSZ2ENQgMlAdRX57qDH0Ugf_9MFhZmfUTi22Zgk" />

<!-- This site is optimized with the Yoast SEO Premium plugin v7.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="original-source" content="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/" />
<link rel="canonical" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Princeton should continue to fund local public television station - Planet Princeton" />
<meta property="og:description" content="FacebookTwitterTo the Editor: I am writing to give my wholehearted support for Princeton Community TV and to show how important it is to continue funding for our valuable community resource. I have followed the development of “TV30” for many years, since it started out from a small office in the Arts Council of Princeton to &hellip;" />
<meta property="og:url" content="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/" />
<meta property="og:site_name" content="Planet Princeton" />
<meta property="article:publisher" content="https://www.facebook.com/PlanetPrinceton/" />
<meta property="article:section" content="Opinionator" />
<meta property="article:published_time" content="2019-05-22T15:56:32-04:00" />
<meta property="article:modified_time" content="2019-05-22T15:56:40-04:00" />
<meta property="og:updated_time" content="2019-05-22T15:56:40-04:00" />
<meta property="og:image" content="https://planetprinceton.com/wp-content/uploads/2015/01/princeton-letter_2.jpg" />
<meta property="og:image:secure_url" content="https://planetprinceton.com/wp-content/uploads/2015/01/princeton-letter_2.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="FacebookTwitterTo the Editor: I am writing to give my wholehearted support for Princeton Community TV and to show how important it is to continue funding for our valuable community resource. I have followed the development of “TV30” for many years, since it started out from a small office in the Arts Council of Princeton to [&hellip;]" />
<meta name="twitter:title" content="Princeton should continue to fund local public television station - Planet Princeton" />
<meta name="twitter:site" content="@planetprinceton" />
<meta name="twitter:image" content="https://planetprinceton.com/wp-content/uploads/2015/01/princeton-letter_2.jpg" />
<meta name="twitter:creator" content="@planetprinceton" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/planetprinceton.com\/","sameAs":["https:\/\/www.facebook.com\/PlanetPrinceton\/","https:\/\/www.instagram.com\/princetonpics\/","https:\/\/twitter.com\/planetprinceton"],"@id":"#organization","name":"Princeton Community Media","logo":"https:\/\/planetprinceton.com\/wp-content\/uploads\/2018\/12\/Plan_Prin_LogoFinal-web-Lg-1-e1544979640969.jpg"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Planet Princeton &raquo; Feed" href="https://planetprinceton.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Planet Princeton &raquo; Comments Feed" href="https://planetprinceton.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Planet Princeton &raquo; iCal Feed" href="https://planetprinceton.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Planet Princeton &raquo; Princeton should continue to fund local public television station Comments Feed" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/planetprinceton.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6b7ce11a56aa480c978260d8e06451de"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='atomic-blocks-fontawesome-css'  href='https://planetprinceton.com/wp-content/plugins/atomic-blocks/dist/assets/fontawesome/css/all.min.css?ver=1557454500' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://planetprinceton.com/wp-includes/css/dist/block-library/style.min.css?ver=6b7ce11a56aa480c978260d8e06451de' type='text/css' media='all' />
<link rel='stylesheet' id='atomic-blocks-style-css-css'  href='https://planetprinceton.com/wp-content/plugins/atomic-blocks/dist/blocks.style.build.css?ver=1557454500' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://planetprinceton.com/wp-content/plugins/metronet-profile-picture/css/front-end-gutenberg.css?ver=2.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='mks_shortcodes_fntawsm_css-css'  href='https://planetprinceton.com/wp-content/plugins/meks-flexible-shortcodes/css/font-awesome/css/font-awesome.min.css?ver=1.3.1' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css'  href='https://planetprinceton.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3.1' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css'  href='https://planetprinceton.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3.1' type='text/css' media='screen' />
<link rel='stylesheet' id='opinion-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%7CSource+Sans+Pro%3A400%2C700&#038;subset=latin&#038;ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='opinion-main-css'  href='https://planetprinceton.com/wp-content/themes/opinion/assets/css/min.css?ver=1.1' type='text/css' media='all' />
<style id='opinion-main-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='meks_instagram-widget-styles-css'  href='https://planetprinceton.com/wp-content/plugins/meks-easy-instagram-widget/css/widget.css?ver=6b7ce11a56aa480c978260d8e06451de' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css'  href='https://planetprinceton.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks_ess-main-css'  href='https://planetprinceton.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://planetprinceton.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1.3.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/542/public/assets/js/advanced.js?ver=1.13.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/291/public/assets/js/997.js?ver=1.8.7'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/414/396/647/assets/js/510.js?ver=2.3.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/planetprinceton.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":0,"offsets":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/414/396/358/234/678.js?ver=2.3.3'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=7.3.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=7.3.1'></script>
<link rel='https://api.w.org/' href='https://planetprinceton.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://planetprinceton.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://planetprinceton.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://planetprinceton.com/?p=74870' />
<link rel="alternate" type="application/json+oembed" href="https://planetprinceton.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://planetprinceton.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://planetprinceton.com"><link rel="https://theeventscalendar.com/" href="https://planetprinceton.com/wp-json/tribe/events/v1/" /><script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="plane-layer-custom-css"></style><script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
			<style type="text/css">
				
				
				
				
				
				
				
				
				
				
				
				
				
				
				
				
				
				
			</style>
			      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://planetprinceton.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://planetprinceton.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '57c6a994-eca0-48fc-a916-74b7ecfa8390';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://planetprinceton.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4bf73218-3550-4659-982d-970270d14d2d";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['colors'] = {};
oneSignal_options['notifyButton']['offset'] = {};
oneSignal_options['notifyButton']['offset']['right'] = '30';
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-140x140.jpg" sizes="32x32" />
<link rel="icon" href="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-275x275.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-275x275.jpg" />
<meta name="msapplication-TileImage" content="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-275x275.jpg" />

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-11051800-3', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
	</head>

	<body class="post-template-default single single-post postid-74870 single-format-standard tribe-no-js tribe-theme-parent-opinion tribe-theme-child-opinion-child02 opinion-sidebar-right opinion-header-borderless opinion-v_1_1">
		
							
<div class="opinion-top-bar d-none d-md-block">
    <div class="container d-flex justify-content-between align-items-center">

                            </div>
</div>			
	        <header id="opinion-header" class="opinion-header">
		        <div class="container d-flex justify-content-between align-items-center">
		            <div class="opinion-slot-l">
   <div class="opinion-site-branding">
    <span class="site-title h1 "><a href="https://planetprinceton.com/" rel="home"><picture class="opinion-logo"><source media="(min-width: 970px)" srcset="https://planetprinceton.com/wp-content/uploads/2013/05/PPBRIGHTLOGO_2.jpg, https://planetprinceton.com/wp-content/uploads/2013/05/planetlogo1.jpg 2x"><source srcset="https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-e1544977452359.jpg, https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-1.jpg 2x"><img src="https://planetprinceton.com/wp-content/uploads/2013/05/PPBRIGHTLOGO_2.jpg" alt="Planet Princeton"></picture></a></span></div> 
</div>
<div class="opinion-slot-r">
   	    <nav class="menu-desktop-menu-container"><ul id="menu-desktop-menu" class="opinion-menu"><li id="menu-item-29926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-29926"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Events</a>
<ul class="sub-menu">
	<li id="menu-item-32697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32697"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/community/add">Add Event</a></li>
	<li id="menu-item-32698" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32698"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Upcoming Events</a></li>
</ul>
</li>
<li id="menu-item-29707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29707"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-32675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32675"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/cops/">Police</a></li>
	<li id="menu-item-32676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32676"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/transit/">Traffic &#038; Transit</a></li>
	<li id="menu-item-68624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-68624"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/">Public Records</a>
	<ul class="sub-menu">
		<li id="menu-item-68626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68626"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/planet-princeton-public-records-clearing-house-project/">Public records survey</a></li>
		<li id="menu-item-68625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68625"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/nj-open-public-records-request-template/">OPRA template</a></li>
	</ul>
</li>
	<li id="menu-item-32686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32686"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/planning-and-development/">Planning</a></li>
	<li id="menu-item-32687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32687"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/realestate/">Real Estate</a></li>
	<li id="menu-item-32682" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32682"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/local-politics/">Local Politics</a></li>
	<li id="menu-item-32683" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32683"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nj-politics/">State House</a></li>
	<li id="menu-item-29758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29758"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/ed/">Higher Ed</a></li>
	<li id="menu-item-29757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29757"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/schools/">Schools</a></li>
	<li id="menu-item-32677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32677"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/weather/">Weather</a></li>
	<li id="menu-item-29742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29742"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/lifestyle/">Lifestyle</a>
	<ul class="sub-menu">
		<li id="menu-item-29711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29711"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/food/">Food</a></li>
		<li id="menu-item-29715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29715"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/culture/">Arts &#038; Culture</a></li>
		<li id="menu-item-29710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29710"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/faith/">Faith &#038; Values</a></li>
		<li id="menu-item-29759" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29759"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nonprofits/">Nonprofits</a></li>
		<li id="menu-item-29728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29728"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/people/">People</a></li>
		<li id="menu-item-29730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29730"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/pets/">Pets</a></li>
		<li id="menu-item-63699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63699"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/adopt-a-princeton-area-pet/">Adopt a pet</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-29708" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29708"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/opinion/">Opinion</a></li>
<li id="menu-item-70259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70259"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/see-click-fix/">See-Click-Fix</a></li>
<li id="menu-item-70253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-70253"><a href="https://planetprinceton.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-72483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72483"><a href="https://mailchi.mp/planetprinceton/subscribe">Daily newsletter sign up</a></li>
	<li id="menu-item-70258" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70258"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/how-to-submit-news-to-planet-princeton/">How to submit news</a></li>
	<li id="menu-item-70256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70256"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-70255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70255"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/planet-princeton-comment-policy/">Comment Policy</a></li>
	<li id="menu-item-70257" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70257"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contributors/">Contributors</a></li>
	<li id="menu-item-70260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70260"><a href="https://donorbox.org/planet-princeton-membership-subscriptions">Support Us</a></li>
</ul>
</li>
<li id="menu-item-70254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70254"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/advertise-2/">Advertise</a></li>
</ul></nav> 
    
	<ul class="opinion-menu-actions">
					<li class="action-el-search"><a href="javascript:void(0);" class="opinion-open-popup"><i class="opinion-icon opinion-icon-search"></i></a>
<div class="opinion-overlay-content">
	<form class="search-form opinion-form-special" action="https://planetprinceton.com/" method="get">
	<span class="h3">Search</span>
	<input name="s" type="text" value="" placeholder="Type here to search..." />
		<button type="submit">Search</button>
</form>
	    <span class="opinion-action-close">
		<i class="opinion-icon opinion-icon-close" aria-hidden="true"></i>
	</span>
</div>
</li>
					<li class="action-el-menu-social">    <ul id="menu-social" class="opinion-menu-social"><li id="menu-item-57644" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57644"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/PlanetPrinceton"><span class="opinion-social-name">Facebook</span></a></li>
<li id="menu-item-57645" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57645"><a href="https://twitter.com/PlanetPrinceton"><span class="opinion-social-name">Twitter</span></a></li>
<li id="menu-item-57647" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57647"><a href="https://www.instagram.com/prinpics/"><span class="opinion-social-name">Instagram</span></a></li>
</ul></li>
					<li class="action-el-hamburger"><a href="" class="opinion-open-sidebar"><i class="opinion-icon opinion-icon-menu"></i></a>
</li>
			</ul>
 
</div>		        </div>
		        <div class="container">
		            <div class="opinion-header-border"></div>
		        </div>
	   		 </header>

	   		 		   		 <div class="opinion-header opinion-header-sticky">
			        <div class="container d-flex justify-content-between align-items-center">
			            
<div class="opinion-slot-l">
   <div class="opinion-site-branding">
    <span class="site-title h1 "><a href="https://planetprinceton.com/" rel="home"><picture class="opinion-logo"><source media="(min-width: 970px)" srcset="https://planetprinceton.com/wp-content/uploads/2013/05/PPBRIGHTLOGO_2.jpg, https://planetprinceton.com/wp-content/uploads/2013/05/planetlogo1.jpg 2x"><source srcset="https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-e1544977452359.jpg, https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-1.jpg 2x"><img src="https://planetprinceton.com/wp-content/uploads/2013/05/PPBRIGHTLOGO_2.jpg" alt="Planet Princeton"></picture></a></span></div> 
</div>
<div class="opinion-slot-r">

             <nav class="menu-desktop-menu-container"><ul id="menu-desktop-menu-1" class="opinion-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-29926"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Events</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32697"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/community/add">Add Event</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32698"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Upcoming Events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29707"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32675"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/cops/">Police</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32676"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/transit/">Traffic &#038; Transit</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-68624"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/">Public Records</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68626"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/planet-princeton-public-records-clearing-house-project/">Public records survey</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68625"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/nj-open-public-records-request-template/">OPRA template</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32686"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/planning-and-development/">Planning</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32687"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/realestate/">Real Estate</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32682"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/local-politics/">Local Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32683"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nj-politics/">State House</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29758"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/ed/">Higher Ed</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29757"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/schools/">Schools</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32677"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/weather/">Weather</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29742"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/lifestyle/">Lifestyle</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29711"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/food/">Food</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29715"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/culture/">Arts &#038; Culture</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29710"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/faith/">Faith &#038; Values</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29759"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nonprofits/">Nonprofits</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29728"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/people/">People</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29730"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/pets/">Pets</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63699"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/adopt-a-princeton-area-pet/">Adopt a pet</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29708"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70259"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/see-click-fix/">See-Click-Fix</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-70253"><a href="https://planetprinceton.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72483"><a href="https://mailchi.mp/planetprinceton/subscribe">Daily newsletter sign up</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70258"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/how-to-submit-news-to-planet-princeton/">How to submit news</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70256"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70255"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/planet-princeton-comment-policy/">Comment Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70257"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contributors/">Contributors</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70260"><a href="https://donorbox.org/planet-princeton-membership-subscriptions">Support Us</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70254"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/advertise-2/">Advertise</a></li>
</ul></nav>   
         
	<ul class="opinion-menu-actions">
					<li class="action-el-search"><a href="javascript:void(0);" class="opinion-open-popup"><i class="opinion-icon opinion-icon-search"></i></a>
<div class="opinion-overlay-content">
	<form class="search-form opinion-form-special" action="https://planetprinceton.com/" method="get">
	<span class="h3">Search</span>
	<input name="s" type="text" value="" placeholder="Type here to search..." />
		<button type="submit">Search</button>
</form>
	    <span class="opinion-action-close">
		<i class="opinion-icon opinion-icon-close" aria-hidden="true"></i>
	</span>
</div>
</li>
					<li class="action-el-menu-social">    <ul id="menu-social-1" class="opinion-menu-social"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57644"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/PlanetPrinceton"><span class="opinion-social-name">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57645"><a href="https://twitter.com/PlanetPrinceton"><span class="opinion-social-name">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57647"><a href="https://www.instagram.com/prinpics/"><span class="opinion-social-name">Instagram</span></a></li>
</ul></li>
					<li class="action-el-hamburger"><a href="" class="opinion-open-sidebar"><i class="opinion-icon opinion-icon-menu"></i></a>
</li>
			</ul>
 
   
</div>			        </div>
		   		 </div>
		   	
	   	
            <div class="opinion-section">
    <div class="container">
        <div class="section-content row justify-content-center">
                        <div class="col-12 col-lg-8 opinion-order-1">
                <article class="opinion-post opinion-single opinion-single-1 post-74870 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion">
                    <div class="entry-header">
                                                <div class="entry-category">
                            <a href="https://planetprinceton.com/category/opinion/" rel="tag" class="cat-62">Opinionator</a>                        </div>
                                                <h1 class="entry-title h1">Princeton should continue to fund local public television station</h1>                                                <div class="entry-meta">
                            <span class="meta-item meta-author"><span class="vcard author"><a href="https://planetprinceton.com/author/opinion/"><img width="30" height="30" src="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-140x140.jpg" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-lazy-srcset="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-140x140.jpg 140w, https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-275x275.jpg 275w, https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-310x310.jpg 310w, https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671.jpg 512w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://planetprinceton.com/wp-content/uploads/2013/05/cropped-planetlogo-e1470432404671-140x140.jpg?is-pending-load=1" />Community Contributor</a></span></span><span class="meta-item meta-rtime">2 min read</span><span class="meta-item meta-date"><span class="updated">10 hours ago</span></span><span class="meta-item meta-comments"><a href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/#respond" class="opinion-scroll-animate">Add comment</a></span>                        </div>
                                            </div>
                                                                                    <div class="entry-content">
    <div class="meks_ess rectangle no-labels solid"><a href="javascript:void(0);" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F&amp;t=Princeton%20should%20continue%20to%20fund%20local%20public%20television%20station"><span>Facebook</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F&amp;text=Princeton%20should%20continue%20to%20fund%20local%20public%20television%20station"><span>Twitter</span></a></div>
<p>To the Editor:</p>



<p>I am writing to give my wholehearted support for Princeton Community TV and to show how important it is to continue funding for our valuable community resource.</p>



<p>I have followed the development of “TV30” for many years, since it started out from a small office in the Arts Council of Princeton to its current facilities with a modern studio, equipment, classes and dozens of talented, dedicated people&nbsp; who create the outstanding programs covering topics important to our community.&nbsp;</p>



<p>Programs such as the Spanda Yoga Program which helped me to modify yoga for my personal limitations.&nbsp; I watch Backstory with Joan Goldstein.&nbsp; A particularly interesting guest on her show was John Leland who spoke optimistically about how to age well. &nbsp; I like to check out the movie review show, Popcorn, with community reviewers instead of written reviews.&nbsp; &nbsp; I would miss all these programs if funding were to be cut. &nbsp;</p>



<p>Not only does PCTV produce these shows, it offers courses and resources to educate people interested in honing their technical skills.&nbsp; My husband is a good example of such a volunteer,&nbsp; starting out as a camera man, who improved with guidance and practice.&nbsp; He was soon directing shows and going on to shoot and edit his own documentaries-one about Princeton-after taking a course.&nbsp; If we were to lose PCTV, there is no local alternative.</p>



<p>In summary, we are so fortunate to have this vibrant organization, I believe the City of Princeton needs to continue generous financial support to keep it flourishing. &nbsp;</p>



<p>My understanding is that PCTV is funded by a cable tv franchise fee.&nbsp; What I don’t understand is why these funds are now being withheld from PCTV. &nbsp;</p>



<p>Sincerely,</p>



<p>Sally Jenkins</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-74870" class="share-facebook sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-74870" class="share-linkedin sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-74870" class="share-twitter sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-74870" class="share-pinterest sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://planetprinceton.com/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-17139534-74870-5ce63213245ee' data-src='https://widgets.wp.com/likes/#blog_id=17139534&amp;post_id=74870&amp;origin=planetprinceton.com&amp;obj_id=17139534-74870-5ce63213245ee' data-name='like-post-frame-17139534-74870-5ce63213245ee'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>        </div>
                </article>
                                                
    
    <div class="opinion-comments section-margin">

        <div class="opinion-comment-form">
            
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please share your thoughts on this story.					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=17139534&#038;postid=74870&#038;comment_registration=0&#038;require_name_email=0&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=blank&#038;greeting=Please+share+your+thoughts+on+this+story.&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=7.3.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;sig=ff22f2da504fa700dd30809087413408cc0bdc9e#parent=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		        </div>

        
    </div>

            </div>
                        <div class="col-12 col-lg-4 opinion-order-2">
                <aside class="opinion-sidebar row">

    
        	<div id="tribe-events-adv-list-widget-3" class="widget tribe-events-adv-list-widget col-12 col-md-6 col-lg-12"><div class="opinion-bg-light"><h4 class="widget-title h6">Upcoming Events</h4>
		<!-- Event  -->
		<div class="type-tribe_events post-70748 tribe-clearfix tribe-events-category-gov tribe-events-venue-74621 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Thu			</span>
		
		<span class="list-daynumber">23</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/mercer-county-surrogate/2019-05-23/" rel="bookmark">Mercer County Surrogate Princeton Satellite Office Hours</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 23 @ 9:30 am</span> - <span class="tribe-event-time">11:30 am</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-74570 tribe-clearfix tribe-events-category-environment tribe-events-category-kids tribe-events-category-nature tribe-events-category-visual-arts tribe-events-venue-67880 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Thu			</span>
		
		<span class="list-daynumber">23</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/eden-school-mural-wild-night/2019-05-23/" rel="bookmark">Eden School Mural &#8220;Wild Night&#8221;</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 23 @ 9:30 am</span> - <span class="tribe-event-time">5:00 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-73981 tribe-clearfix tribe-events-category-visual-arts tribe-events-venue-59919 tribe-events-organizer-31540 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Thu			</span>
		
		<span class="list-daynumber">23</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/final-runnings-before-the-after-an-exhibition-presented-by-the-lewis-center-for-the-arts-program-in-visual-arts/2019-05-23/" rel="bookmark">Final Runnings Before the After, an exhibition presented by the Lewis Center for the Arts’ Program in Visual Arts</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 23 @ 10:00 am</span> - <span class="tribe-event-time">8:30 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-74680 tribe-clearfix tribe-events-category-food tribe-events-venue-67736 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Thu			</span>
		
		<span class="list-daynumber">23</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/princeton-farmers-market-summer-outdoor-market/2019-05-23/" rel="bookmark">Princeton Farmers&#8217; Market Summer Outdoor Market</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 23 @ 10:00 am</span> - <span class="tribe-event-time">3:00 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-73553 tribe-clearfix tribe-events-category-food tribe-events-venue-65628 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Thu			</span>
		
		<span class="list-daynumber">23</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/rutgers-cooperative-extension-presents-fruit-and-vegetable-freezing-and-dehydrating-workshop/" rel="bookmark">Rutgers Cooperative Extension Presents Fruit and Vegetable Freezing and Dehydrating Workshop</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 23 @ 1:00 pm</span> - <span class="tribe-event-time">3:00 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-71463 tribe-clearfix tribe-events-category-books tribe-events-category-kids tribe-events-category-free tribe-events-venue-32989 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Fri			</span>
		
		<span class="list-daynumber">24</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/friday-fun-day-storytime-at-barnes-noble/2019-05-24/" rel="bookmark">Friday Fun Day Storytime at Barnes &#038; Noble</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 24 @ 11:00 am</span> - <span class="tribe-event-time">11:30 am</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-73637 tribe-clearfix tribe-events-category-free tribe-events-category-holiday tribe-events-venue-19714 tribe-events-first tribe-events-last">
			
<div class="tribe-mini-calendar-event event-0  first  last ">
	
	<div class="list-date">
					<span class="list-dayname">
				Sat			</span>
		
		<span class="list-daynumber">25</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://planetprinceton.com/event/lawrence-memorial-day-observance/" rel="bookmark">Lawrence Memorial Day Observance</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 25 @ 10:00 am</span> - <span class="tribe-event-time">12:00 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<p class="tribe-events-widget-link">
		<a href="https://planetprinceton.com/events/" rel="bookmark">
			View More&hellip;		</a>
	</p>
	
</div></div><script type="application/ld+json">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</script>    
    
</aside>            </div>
                    </div>
    </div>
</div>    

    
            

            <div class="opinion-section-instagram">

        <div id="widget_meks_instagram" class="widget widget_meks_instagram"><div class="meks-instagram-widget" style="max-width: 1200px; margin: -0px;">
		
	
				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/Bxf4vHrntf7/" title="Princeton University Professor Alain Kornhauser shows some love to Olli, the automated driverless shuttle, at the Smart Driving Car conference today. #princeton #automatedvehicles #mobility" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/98ec7f7b177a0ba8982e630a6faa3dd9/5D9CEE2C/t51.2885-15/e35/s240x240/59505517_163535348005744_2457697218988890039_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Princeton University Professor Alain Kornhauser shows some love to Olli, the automated driverless shuttle, at the Smart Driving Car conference today. #princeton #automatedvehicles #mobility">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BxKlOJbntsB/" title="Students prepare for a rally to protest the Title IX sexual assault hearing process at Princeton University. #princeton #princetonuniversity #sexualassault #titleix" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/a276be9c73dcb04915f54b16d6e25747/5D68CCAD/t51.2885-15/e35/s240x240/58409619_2167911056852239_3011391403458366361_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Students prepare for a rally to protest the Title IX sexual assault hearing process at Princeton University. #princeton #princetonuniversity #sexualassault #titleix">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BwQKr6RnMz5/" title="The view from Washington Rd leaving #princeton" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/7d4bf34dc0d646e3ea90751178bef718/5D617D0E/t51.2885-15/e35/s240x240/55928071_419801915473882_5441741227572806766_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="The view from Washington Rd leaving #princeton">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BvvDlUPINV2/" title="Up next in Princeton - subscribe to our newsletter for the photo of the day, event info. and more.  Visit planetprinceton.com to subscribe." target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/03739c4912cc0904114237c2e3dca596/5D649824/t51.2885-15/e15/c212.0.655.655a/s240x240/54226112_2270597743207179_2652610124013508_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Up next in Princeton - subscribe to our newsletter for the photo of the day, event info. and more.  Visit planetprinceton.com to subscribe.">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BvPGPRdHyoH/" title="The payphone at @chubbys_luncheonette works. A little boy asked us how to use it. We showed him how to dial. His response: “But how do I text?” #payphone #nostalgia #feelingold  #technology  #Hopewell" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/eef2ab3a53817f90005f9a199d3b3f3d/5D6B67E6/t51.2885-15/e35/s240x240/53190890_158310225112996_6436403795317254898_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="The payphone at @chubbys_luncheonette works. A little boy asked us how to use it. We showed him how to dial. His response: “But how do I text?” #payphone #nostalgia #feelingold  #technology  #Hopewell">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BvC1GtClDNr/" title="Best elixir for a cold - chicken pho from @thephospotprinceton Thanks Tom! #pho #coldcures #princeton" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/81a6c8a077288781d477e1176ebc21e7/5D9BAA39/t51.2885-15/e35/s240x240/52706567_575933362912967_4239378664534559002_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Best elixir for a cold - chicken pho from @thephospotprinceton Thanks Tom! #pho #coldcures #princeton">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BuMPhPOHYiP/" title="Seen at 42nd subway while walking to the S train. #tgif" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/f204bbdb74de683f8c69e6f63610664a/5D636A3E/t51.2885-15/e35/s240x240/50790057_561042951040284_4035645711295598394_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Seen at 42nd subway while walking to the S train. #tgif">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BuHRuJGnPpa/" title="Stay in if you can! Princeton area roads were slippery when we were out. #winter #snow #nj #princeton" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/f4a484f821e8dddc80405310cdbc1600/5D98D286/t51.2885-15/e35/s240x240/51151543_424176211684532_1261503745578934101_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Stay in if you can! Princeton area roads were slippery when we were out. #winter #snow #nj #princeton">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BuCVUeDnMYB/" title="This Tues. at 6 pm - public forum with NJ Transit regarding Dinky train restoration. Meeting is at the station. #dinky #trains #princeton #njtransit #nj #commuter" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/3a071a190e910e65da875795bc9e4757/5D804528/t51.2885-15/e35/c70.0.179.179a/50988342_393723078071006_4126202290294530148_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="This Tues. at 6 pm - public forum with NJ Transit regarding Dinky train restoration. Meeting is at the station. #dinky #trains #princeton #njtransit #nj #commuter">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/Bt9CzeonDYm/" title="Volunteers gearing up and organizing books for the Bryn Mawr Wellesley book sale next month. Books accepted until Feb. 27. #princeton  #books #scholarships" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/bc518d8244428023be3870330cc733b5/5D7C8F96/t51.2885-15/e35/s240x240/51380788_2187954664777568_3149590362871662327_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Volunteers gearing up and organizing books for the Bryn Mawr Wellesley book sale next month. Books accepted until Feb. 27. #princeton  #books #scholarships">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BtjSRn4n_H2/" title="Aunt Chubby’s in Hopewell Borough is finally open again. The space is beautiful. Story to be posted soon." target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/505b05450a0717b9bb9272ac9158b754/5D7CEFA4/t51.2885-15/e35/s240x240/50075662_2293917187600748_7234049126522369881_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="Aunt Chubby’s in Hopewell Borough is finally open again. The space is beautiful. Story to be posted soon.">
				</a>

			</div>

				
			<div style="padding: 0px; -webkit-box-flex: 0;-ms-flex: 0 0 20%; flex: 0 0 20%; ">

				<a href="https://instagram.com/p/BteLUk4n2Wk/" title="It’s great to finally get outside and make some Vitamin D today! @designatdohmalley" target="_blank" rel="nofollow">
					<img src="//scontent-iad3-1.cdninstagram.com/vp/84c34fa8bf29290254029acb88e297c3/5D9F5517/t51.2885-15/e35/s240x240/50809189_250358032573025_208052762437779615_n.jpg?_nc_ht=scontent-iad3-1.cdninstagram.com" alt="It’s great to finally get outside and make some Vitamin D today! @designatdohmalley">
				</a>

			</div>

		
	
</div>

	
	<p class="meks-instagram-follow-link">
		<a href="https://instagram.com/princetonpics" target="_blank" rel="nofollow" class="mks_author_link meks-widget-cta"><i class="fa fa-instagram"></i> Follow</a>
	</p>

</div>        
        </div>

    
    
    <footer id="opinion-footer" class="opinion-footer">
        <div class="container">
                            <div class="opinion-prefooter">

   	   	 	<a href="https://planetprinceton.com/"><img src="https://planetprinceton.com/wp-content/uploads/2018/12/planet-logo-princeton-e1545094264325.png" alt="Planet Princeton"></a>
    
              <ul id="menu-social-2" class="opinion-menu-social"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57644"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/PlanetPrinceton"><span class="opinion-social-name">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57645"><a href="https://twitter.com/PlanetPrinceton"><span class="opinion-social-name">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57647"><a href="https://www.instagram.com/prinpics/"><span class="opinion-social-name">Instagram</span></a></li>
</ul>    
</div>
            
                            
	<div class="row opinion-footer-widgets justify-content-center">
	    	        	            <div class="col-12 col-md-6 col-lg-5">
		            <div id="media_image-8" class="widget widget_media_image "><h5 class="widget-title h6">Contact Us</h5><a href="https://planetprinceton.com/tips/" target="_blank" rel="noopener noreferrer"><img width="275" height="229" src="https://planetprinceton.com/wp-content/uploads/2017/07/Got-a-confidential-news-tip-2-275x229.jpg" class="image wp-image-59155  attachment-medium size-medium jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-lazy-srcset="https://planetprinceton.com/wp-content/uploads/2017/07/Got-a-confidential-news-tip-2-275x229.jpg 275w, https://planetprinceton.com/wp-content/uploads/2017/07/Got-a-confidential-news-tip-2.jpg 300w" data-lazy-sizes="(max-width: 275px) 100vw, 275px" data-lazy-src="https://planetprinceton.com/wp-content/uploads/2017/07/Got-a-confidential-news-tip-2-275x229.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>	            </div>
	        	    	        	            <div class="col-12 col-md-6 col-lg-4">
		            <div id="onesignalwidget-4" class="widget widget_onesignalwidget"><h5 class="widget-title h6">Follow</h5><a href="#" class="OneSignal-prompt">Want to receive news updates via your browser? Click and you will be subscribed to our push notification service. </a></div><div id="media_image-11" class="widget widget_media_image"><h5 class="widget-title h6">See Click Fix</h5><a href="https://planetprinceton.com/see-click-fix/"><img width="229" height="229" src="https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-275x275.jpg" class="image wp-image-11833  attachment-229x229 size-229x229 jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-lazy-srcset="https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-275x275.jpg 275w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-150x150.jpg 150w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-100x100.jpg 100w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-300x300.jpg 300w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-140x140.jpg 140w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-310x310.jpg 310w, https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix.jpg 450w" data-lazy-sizes="(max-width: 229px) 100vw, 229px" data-lazy-src="https://planetprinceton.com/wp-content/uploads/2014/01/seeclickfix-275x275.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>	            </div>
	        	    	        	            <div class="col-12 col-md-6 col-lg-3">
		            <div id="tribe-mini-calendar-19" class="widget tribe_mini_calendar_widget"><h5 class="widget-title h6">Events Calendar</h5>
<!-- Removing this wrapper class will break the calendar JavaScript, please avoid and extend as needed -->

<div class="tribe-mini-calendar-wrapper">

	<!-- Grid -->
	
<div class="tribe-mini-calendar-grid-wrapper">
	<table class="tribe-mini-calendar"  data-count="0" data-eventDate="2019-05-01" data-tax-query="" data-nonce="1ed6ba86f1">
				<thead class="tribe-mini-calendar-nav">
		<tr>
			<td colspan="7">
				<div>
					<a class="tribe-mini-calendar-nav-link prev-month" href="#" data-month="2019-04-01" title="April"><span>&laquo;</span></a>					<span id="tribe-mini-calendar-month-0">May 2019</span>
					<a class="tribe-mini-calendar-nav-link next-month" href="#" data-month="2019-06-01" title="June"><span>&raquo;</span></a>					<img id="ajax-loading-mini" src="https://planetprinceton.com/wp-content/plugins/the-events-calendar/src/resources/images/tribe-loading.gif" alt="loading..." />
				</div>
			</td>
		</tr>
						<tr>
							<th class="tribe-mini-calendar-dayofweek">M</th>
							<th class="tribe-mini-calendar-dayofweek">T</th>
							<th class="tribe-mini-calendar-dayofweek">W</th>
							<th class="tribe-mini-calendar-dayofweek">T</th>
							<th class="tribe-mini-calendar-dayofweek">F</th>
							<th class="tribe-mini-calendar-dayofweek">S</th>
							<th class="tribe-mini-calendar-dayofweek">S</th>
			
		</tr>
		</thead>

		<tbody>

		<tr>
									<td class="tribe-events-othermonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-29">
				


	<div id="daynum-29-0">
		<a href="https://planetprinceton.com/events/2019-04-29/" data-day="2019-04-29" rel="prev">29</a>	</div>

			</td>
									<td class="tribe-events-othermonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-30">
				


	<div id="daynum-30-0">
		<a href="https://planetprinceton.com/events/2019-04-30/" data-day="2019-04-30" rel="prev">30</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-01">
				


	<div id="daynum-1-0">
		<a href="https://planetprinceton.com/events/2019-05-01/" data-day="2019-05-01" rel="prev">1</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-02">
				


	<div id="daynum-2-0">
		<a href="https://planetprinceton.com/events/2019-05-02/" data-day="2019-05-02" rel="prev">2</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-03 tribe-events-right">
				


	<div id="daynum-3-0">
		<a href="https://planetprinceton.com/events/2019-05-03/" data-day="2019-05-03" rel="prev">3</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-04 tribe-events-right">
				


	<div id="daynum-4-0">
		<a href="https://planetprinceton.com/events/2019-05-04/" data-day="2019-05-04" rel="prev">4</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-05 tribe-events-right">
				


	<div id="daynum-5-0">
		<a href="https://planetprinceton.com/events/2019-05-05/" data-day="2019-05-05" rel="prev">5</a>	</div>

			</td>
								</tr>
		<tr>
						<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-06">
				


	<div id="daynum-6-0">
		<a href="https://planetprinceton.com/events/2019-05-06/" data-day="2019-05-06" rel="prev">6</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-07">
				


	<div id="daynum-7-0">
		<a href="https://planetprinceton.com/events/2019-05-07/" data-day="2019-05-07" rel="prev">7</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-08">
				


	<div id="daynum-8-0">
		<a href="https://planetprinceton.com/events/2019-05-08/" data-day="2019-05-08" rel="prev">8</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-09">
				


	<div id="daynum-9-0">
		<a href="https://planetprinceton.com/events/2019-05-09/" data-day="2019-05-09" rel="prev">9</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-10 tribe-events-right">
				


	<div id="daynum-10-0">
		<a href="https://planetprinceton.com/events/2019-05-10/" data-day="2019-05-10" rel="prev">10</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-11 tribe-events-right">
				


	<div id="daynum-11-0">
		<a href="https://planetprinceton.com/events/2019-05-11/" data-day="2019-05-11" rel="prev">11</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-12 tribe-events-right">
				


	<div id="daynum-12-0">
		<a href="https://planetprinceton.com/events/2019-05-12/" data-day="2019-05-12" rel="prev">12</a>	</div>

			</td>
								</tr>
		<tr>
						<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-13">
				


	<div id="daynum-13-0">
		<a href="https://planetprinceton.com/events/2019-05-13/" data-day="2019-05-13" rel="prev">13</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-14">
				


	<div id="daynum-14-0">
		<a href="https://planetprinceton.com/events/2019-05-14/" data-day="2019-05-14" rel="prev">14</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-15">
				


	<div id="daynum-15-0">
		<a href="https://planetprinceton.com/events/2019-05-15/" data-day="2019-05-15" rel="prev">15</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-16">
				


	<div id="daynum-16-0">
		<a href="https://planetprinceton.com/events/2019-05-16/" data-day="2019-05-16" rel="prev">16</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-17 tribe-events-right">
				


	<div id="daynum-17-0">
		<a href="https://planetprinceton.com/events/2019-05-17/" data-day="2019-05-17" rel="prev">17</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-18 tribe-events-right">
				


	<div id="daynum-18-0">
		<a href="https://planetprinceton.com/events/2019-05-18/" data-day="2019-05-18" rel="prev">18</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-19 tribe-events-right">
				


	<div id="daynum-19-0">
		<a href="https://planetprinceton.com/events/2019-05-19/" data-day="2019-05-19" rel="prev">19</a>	</div>

			</td>
								</tr>
		<tr>
						<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-20">
				


	<div id="daynum-20-0">
		<a href="https://planetprinceton.com/events/2019-05-20/" data-day="2019-05-20" rel="prev">20</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-21">
				


	<div id="daynum-21-0">
		<a href="https://planetprinceton.com/events/2019-05-21/" data-day="2019-05-21" rel="prev">21</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-past tribe-events-has-events mobile-trigger tribe-event-day-22">
				


	<div id="daynum-22-0">
		<a href="https://planetprinceton.com/events/2019-05-22/" data-day="2019-05-22" rel="prev">22</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-present tribe-events-has-events mobile-trigger tribe-event-day-23">
				


	<div id="daynum-23-0">
		<a href="https://planetprinceton.com/events/2019-05-23/" data-day="2019-05-23" rel="prev">23</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-24 tribe-events-right">
				


	<div id="daynum-24-0">
		<a href="https://planetprinceton.com/events/2019-05-24/" data-day="2019-05-24" rel="prev">24</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-25 tribe-events-right">
				


	<div id="daynum-25-0">
		<a href="https://planetprinceton.com/events/2019-05-25/" data-day="2019-05-25" rel="prev">25</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-26 tribe-events-right">
				


	<div id="daynum-26-0">
		<a href="https://planetprinceton.com/events/2019-05-26/" data-day="2019-05-26" rel="prev">26</a>	</div>

			</td>
								</tr>
		<tr>
						<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-27">
				


	<div id="daynum-27-0">
		<a href="https://planetprinceton.com/events/2019-05-27/" data-day="2019-05-27" rel="prev">27</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-28">
				


	<div id="daynum-28-0">
		<a href="https://planetprinceton.com/events/2019-05-28/" data-day="2019-05-28" rel="prev">28</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-29">
				


	<div id="daynum-29-1">
		<a href="https://planetprinceton.com/events/2019-05-29/" data-day="2019-05-29" rel="prev">29</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-30">
				


	<div id="daynum-30-1">
		<a href="https://planetprinceton.com/events/2019-05-30/" data-day="2019-05-30" rel="prev">30</a>	</div>

			</td>
									<td class="tribe-events-thismonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-31 tribe-events-right">
				


	<div id="daynum-31-0">
		<a href="https://planetprinceton.com/events/2019-05-31/" data-day="2019-05-31" rel="prev">31</a>	</div>

			</td>
									<td class="tribe-events-othermonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-01 tribe-events-right">
				


	<div id="daynum-1-1">
		<a href="https://planetprinceton.com/events/2019-06-01/" data-day="2019-06-01" rel="prev">1</a>	</div>

			</td>
									<td class="tribe-events-othermonth tribe-events-future tribe-events-has-events mobile-trigger tribe-event-day-02 tribe-events-right">
				


	<div id="daynum-2-1">
		<a href="https://planetprinceton.com/events/2019-06-02/" data-day="2019-06-02" rel="prev">2</a>	</div>

			</td>
					</tr>
		</tbody>
			</table>
</div> <!-- .tribe-mini-calendar-grid-wrapper -->
<script type="application/ld+json">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</script>
	<!-- List -->
	
</div>
</div>	            </div>
	        	    	</div>
            
                            <div class="opinion-postfooter">
                    Created by Princeton Community Media</a> &middot; Powered by our readers&middot; Copyright 2019 &middot; All rights reserved.                </div>
                    </div>

    </footer>

    
    <div class="opinion-action-overlay">

</div>
    <div class="opinion-sidebar opinion-sidebar-hidden">

	<div class="opinion-sidebar-branding">
	    <span class="site-title h1 "><a href="https://planetprinceton.com/" rel="home"><picture class="opinion-logo"><source media="(min-width: 970px)" srcset="https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-e1544977452359.jpg, https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-1.jpg 2x"><source srcset="https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-e1544977452359.jpg, https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-1.jpg 2x"><img src="https://planetprinceton.com/wp-content/uploads/2018/12/Plan_Prin_LogoFinal-web-Lg-e1544977452359.jpg" alt="Planet Princeton"></picture></a></span>	    <span class="opinion-action-close"><i class="opinion-icon opinion-icon-close" aria-hidden="true"></i></span>
	</div>	

	<div class="opinion-menu-mobile widget d-md-block d-lg-none">
		<div class="opinion-bg-light">
			    <nav class="menu-desktop-menu-container"><ul id="menu-desktop-menu-2" class="opinion-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-29926"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Events</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32697"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/community/add">Add Event</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32698"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/events/">Upcoming Events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29707"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32675"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/cops/">Police</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32676"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/transit/">Traffic &#038; Transit</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-68624"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/">Public Records</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68626"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/planet-princeton-public-records-clearing-house-project/">Public records survey</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68625"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/public-records/nj-open-public-records-request-template/">OPRA template</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32686"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/planning-and-development/">Planning</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32687"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/realestate/">Real Estate</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32682"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/local-politics/">Local Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32683"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nj-politics/">State House</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29758"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/ed/">Higher Ed</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29757"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/schools/">Schools</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32677"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/weather/">Weather</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29742"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/lifestyle/">Lifestyle</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29711"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/food/">Food</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29715"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/culture/">Arts &#038; Culture</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29710"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/faith/">Faith &#038; Values</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29759"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/nonprofits/">Nonprofits</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29728"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/people/">People</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29730"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/pets/">Pets</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63699"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/adopt-a-princeton-area-pet/">Adopt a pet</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29708"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70259"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/see-click-fix/">See-Click-Fix</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-70253"><a href="https://planetprinceton.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72483"><a href="https://mailchi.mp/planetprinceton/subscribe">Daily newsletter sign up</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70258"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/how-to-submit-news-to-planet-princeton/">How to submit news</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70256"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70255"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/planet-princeton-comment-policy/">Comment Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70257"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/contributors/">Contributors</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70260"><a href="https://donorbox.org/planet-princeton-membership-subscriptions">Support Us</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70254"><a target="_blank" rel="noopener noreferrer" href="https://planetprinceton.com/advertise-2/">Advertise</a></li>
</ul></nav> 
		</div>
	</div>

    	    <div id="mks_social_widget-3" class="widget mks_social_widget"><div class="opinion-bg-light"><h4 class="widget-title h6">Join Our Orbit</h4>
		
							<ul class="mks_social_widget_ul">
			  		  		<li><a href="https://facebook.com/planetprinceton" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>facebook</span></a></li>
		  			  		<li><a href="https://twitter.com/planetprinceton" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>twitter</span></a></li>
		  			  		<li><a href="https://www.instagram.com/prinpics/" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>instagram</span></a></li>
		  			  </ul>
		

		</div></div>    </div>
    

<script>
		var advanced_ads_ga_UID = false;
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();</script><!--
The IP2Location Country Blocker is using IP2Location LITE geolocation database. Please visit http://lite.ip2location.com for more information.
-->
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<script type="text/javascript">
		function atomicBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}
	</script>
			<!-- Quantcast Tag -->
		<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-GpnREG2x5sCPx",
				source:"wp"
			});
		</script>

		<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-GpnREG2x5sCPx.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>
		<!-- End Quantcast tag -->
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"716e25ecad","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/planetprinceton.com\/2019\/05\/22\/princeton-should-continue-to-fund-local-public-television-station\/":74870};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2019/05/22/princeton-should-continue-to-fund-local-public-television-station/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://planetprinceton.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='widget-calendar-pro-style-css'  href='https://planetprinceton.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-full.min.css?ver=4.6.1' type='text/css' media='all' />
<style id='widget-calendar-pro-style-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.min.js?ver=2.2.0'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201921'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js?ver=1.2.15.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailoptin_globals = {"public_js":"https:\/\/planetprinceton.com\/wp-content\/plugins\/mailoptin\/src\/core\/src\/assets\/js\/src","mailoptin_ajaxurl":"\/2019\/05\/22\/princeton-should-continue-to-fund-local-public-television-station\/?mailoptin-ajax=%%endpoint%%","is_customize_preview":"false","disable_impression_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/mailoptin/src/core/src/assets/js/mailoptin.min.js?ver=1.2.15.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"plane-layer"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/188/public/assets/js/79.js?ver=1.6.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"plane-sticky"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/328/public/assets/js/769.js?ver=1.7.8'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/atomic-blocks/dist/assets/js/dismiss.js?ver=1557454500'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var opinion_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"100","header_sticky_up":"1","single_sticky_bottom":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/themes/opinion/assets/js/min.js?ver=1.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js?ver=1.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/planetprinceton.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":null,"blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/uploads/382/589/public/assets/js/997.js?ver=1.8.15'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=7.3.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-includes/js/wp-embed.min.js?ver=6b7ce11a56aa480c978260d8e06451de'></script>
<script async="async" type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var TribeMiniCalendar = {"ajaxurl":"https:\/\/planetprinceton.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/events-calendar-pro/src/resources/js/widget-calendar.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/js/bootstrap-datepicker.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/the-events-calendar/vendor/jquery-resize/jquery.ba-resize.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/the-events-calendar/vendor/jquery-placeholder/jquery.placeholder.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_js_config = {"permalink_settings":"\/%year%\/%monthnum%\/%day%\/%postname%\/","events_post_type":"tribe_events","events_base":"https:\/\/planetprinceton.com\/events\/","debug":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/the-events-calendar/src/resources/js/tribe-events.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var TribeCalendar = {"ajaxurl":"https:\/\/planetprinceton.com\/wp-admin\/admin-ajax.php","post_type":"tribe_events"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/the-events-calendar/src/resources/js/tribe-events-ajax-calendar.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://planetprinceton.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.3.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201921#ver=201921' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=17139534&postid=74870&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Please+share+your+thoughts+on+this+story.&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.3.1&show_cookie_consent=10&has_cookie_consent=0&sig=ff22f2da504fa700dd30809087413408cc0bdc9e#parent=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=17139534&postid=74870&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Please+share+your+thoughts+on+this+story.&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=7.3.1&show_cookie_consent=10&has_cookie_consent=0&sig=ff22f2da504fa700dd30809087413408cc0bdc9e#parent=https%3A%2F%2Fplanetprinceton.com%2F2019%2F05%2F22%2Fprinceton-should-continue-to-fund-local-public-television-station%2F";
					}
				};

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201921.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.3.1',blog:'17139534',post:'74870',tz:'-4',srv:'planetprinceton.com'} ]);
	_stq.push([ 'clickTrackerInit', '17139534', '74870' ]);
</script>
<script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script></body>

</html>
